Frage

Chaos auf der A1 Hybrid Box - Port Weiterleitung|IP-Adressen|MAC-Adressen

  • 21 March 2024
  • 7 Antworten
  • 105 Ansichten

Abzeichen

Hi,

    ich habe 2 Webcams, 3 Handys, 2 IOT und 2 PCs (Windows10, Ubuntu-22.04) über Wireless mit der Hybrid Box und einem Extender verbunden. Sie sind von aussen über Port Forwarding zugänglich wenn alles funktioniert. 

Allerdings:

  1. Der Windows PC bekommt zwei identische IP Adressen mit unterschiedlichen MAC Adressen zugewiesen (beide werden als ‘aktiv’ angezeigt). Eine davon ist die am PC angezeigte (wo die zweite herkommt weiss ich nicht). Am PC ist KEINE fixe IP Adresse eingestellt (“Eigenschaften von WLAN > Internetprotokoll Version 4 > Allgemein > Folgende IP Adresse verwenden” ist leer. Auf der Hybrid Box ist auch keine fixe IP reserviert. Trotzdem bekommt der PC immer dieselbe IP Adresse mit zwei verschiedenen MAC Adressen zugewiesen. Das ist verwirrend, scheint aber die Funktion nicht zu beinträchtigen. Kann ich die irrelevante irgendwie los werden?
  2. Eine der Kameras bekommt auch dieselbe IP Adresse zwei Mal mit unterschiedlichen MAC Adressen zugewiesen. Die IP Adresse ist an der Webcam fix eingestellt. Nur eine davon ist die Richtige, die andere entspricht keinem der verbundenen Geräte. Es ist KEINE IP Adresse auf der Hybrid Box reserviert. Wie krieg ich die los?
  3. Das Port Forwarding wird im Laufe der Zeit immer komplizierter weil immer mehr MAC Adressen in der Liste aufscheinen aus der man das Gerät auswählen muss dessen Port man forwarden will. Manche davon sind doppelt und dreifach angeführt. Wie kann man die los werden? Welche der mehrfach angeführten nimmt man? Ich habe inzwischen etwa 25 MAC Adressen in dieser Liste. 
  4. Das alles ist extrem verwirrend und ich habe es langsam satt nach jedem Neustart alles wieder neu zu konfigurieren und die einzelnen MAC Adressen auszuprobieren ob sie nun funktionieren.

Gibt es eine einfache Möglichkeit? Ganz von Vorne anfangen will ich nicht, das kostet mich auch viel Zeit und es sammelt sich wieder extrem viel Mist in den Listen an….

Danke für Hinweise!


7 Antworten

Benutzerebene 7
Abzeichen +9

Eigener Router? *

Verbessert auch gleich die Möglichkeiten die Sicherheit zu erhöhen wenn du schon Ports offen hast.

 

Da kannst dann auch die Einstellungen exportieren und damit sichern.

 

* Sofern du kein xplore TV hast 

Abzeichen

Danke, ja wird wohl am besten sein. Das Hybridmodem ist ein Horror....

Benutzerebene 7
Abzeichen +9

@dieter-erich ah sorry, Hybrid kannst leider nicht ersetzen, zumindest ist glaub keine Methode bekannt. 
Da müsstest du vom Hybrid weg auf rein DSL.

Benutzerebene 7
Abzeichen +8

Ich vermute dein Extender ist die Schwachstelle.

Jenachdem ob das jeweilige Gerät direkt verbunden ist (korekte MAC) oder über den Extender, der sie mit zufälligen MAC-Adressen an den Router weiterreicht, kommt das Problem zustande.

Tausche den Extender in ein “besseres” Gerät, damit sollte es behoben sein.
Oder kannst dort was konfigurieren um ihm das abzugewöhnen?

Abzeichen

Hi,

   Danke für die Vorschläge! Ich denke, der Extender/Repeater ist nicht schlecht : NETGEAR WLAN Repeater EX6120 WLAN Verstärker, AC1200 Dual Band WiFi, Abdeckung 2 bis 3 Räume & 20 Geräte, Geschwindigkeit bis zu 1200 MBit/s, kompaktes Design. Der sollte eigentlich korrekt funktionieren.

Ich habe ihn so eingestellt, dass er die IP Adressen einfach weitergeben soll. Allerdings zeigt er, wie von Grisu vermutet, zusätzlich zu den ‘richtigen’ auch “virtuelle MAC Adressen”. Offensichtlich führt das dazu, dass zwei verschiedene MAC Adressen im GUI des Hybridmodems für dieselbe IP Adresse angezeigt werden. Man muss also durchprobieren welche für das Port Forwarding funktioniert und welche nicht. Interessanterweise hat sich alles nach etwa einem Tag ‘eingependelt’. Offenbar dauert es so lange bis die Einstellungen definitv übernommen und auch korrekt angezeigt werden. 

Wenn man genug herumspielt und viel Geduld hat scheint es letztendlich zu funktionieren. Mal sehen, was nach einer Stromunterbrechung passiert. Ich hoffe, dass ich dann nicht wieder alles neu einstellen muss. Ein Backup der Einstellungen hat das Hybridmodem ja auch nicht. Und, wie schon gesagt, jedes Mal gibt es noch mehr IP und MAC Adressen für aktive Geräte in den Listen. Nicht eben besonders hilfreich…..

Benutzerebene 7
Abzeichen +8

Dann wird der Repeater wohl noch andere Einstellungsoptionen haben, wo er sich kompatibler zeigt. Die Hybridbox kann nur anzeigen, was ihr vom Repeater weitergemeldet wird. Also sollte man es dem abgewöhnen zufällige MAC-Adressen für angeschlossene Geräte zu vergeben.

Abzeichen

Hab nochmal nachgesehen: Der Repeater hat keine andere Einstellmöglichkeit. Alle im GUI des Repeaters aufscheinenden Geräte haben eine “normale” und  eine virtuelle MAC Adresse die mit 02:0F:B5 beginnt. Manche davon scheinen im GUI des Hybridmodems auf, manche nicht. Manche davon doppelt manche einfach. Ich finde keine Einstellmöglichkeit wo man ihm abgewöhnen könnte virtuelle Adressen zu vergeben…..

Das ist alles sehr verwirrend, aber solange es nun funktioniert soll es mir recht sein :-), Wie gesagt, nach Neustart kommt das meist wieder durcheinander. Wahrscheinlich durch die zufällige Zuteilung der virtuellen Adressen. Das nächste Mal werde ich darauf achten keine der oben angeführten MAC Adressen im Port Forwarding zu benutzen…...

Antworten