Beantwortet

Huawei E5186 - Port Forwarding einrichten


Benutzerebene 3
Hallo!
Versuche seit Tagen Portforwarding am E5186 zu aktivieren.
Habe unter "virtueller Server" den Port 80 und den Port 3000 auf Adressen in meinem Lan ohne Erfolg aktiviert.
Firwall im Gerät ist down. Zusätzlich habe ich mir im Servicecenter die A1-Firewall deaktivieren lassen.
Trace und Ping gehen bis zur zugewiesenen öffeltichen IP aber die Ports erschein nach Außen "geclosed".
Mit scheint, als unterstütz die aktuelle Firmware kein Portforwarding.
Kann isch das vielleich ein A1-MA mal anschauen?
Bin seit 1973 in der EDV tätig und glaube, mich in der Netzwerktechnik einigermaßen auszukennen.
LG
Hartmut
icon

Beste Antwort von Gringolito 15 March 2016, 08:33

Original anzeigen

45 Antworten

Benutzerebene 7
Abzeichen +2
Im Zielhost (NAS, Kamera, was immer) nicht nur eine fixe lokale Adresse einstellen, sondern auch die Gatewayadresse eintragen.
Benutzerebene 3
Ja, das mit dem Gateway is klar. Nur die Porst am E5186 erscheinen nach außen hin immer geclosed, egal was man einträgt. Denke, das ist ein FW Bug.
Benutzerebene 7
Abzeichen +2
Um sicher zu gehen:
Die im Gateway eingetragene ip-Adresse muss wirklich öffentlich sein. Auch wenn es keine Adresse aus dem lokalen Netz von A1 ist kann sie nochmal im A1- Netz genattet sein.

Test: Auf folgender Seite wird die Adresse aus dem Internet angezeigt. Wenn sie nicht übereinstimmt mit der eingetragenen Adresse im lokalen Gateway, dann ist sie nochmal genattet und somit kein Zugriff aus dem Internet möglich.

http://ping.eu/
Benutzerebene 3
Im Moment habe ich 46.206.49.15 (ist ja kein Geheimnis) die sich auch via Trace lokalisieren lässt.
Nur alle Ports sind zu.
So sieht es im Router aus:

Benutzerebene 3
Der Huawei E5186 (gateway) spuckt folgende Adresse aus
WAN IP-Adresse:46.206.49.15

ping.eu sagt meine IP ist 46.206.49.15
somit identisch.
Woran liegt es dann?
Benutzerebene 7
Abzeichen +2
Aus dem lokalen Netz antwortet der Webserver bei Eingabe von http://192.168.0.9 im Webbrowser?

Nachtrag:

Der Port zeigt sich nämlich nur offen, wenn der Host, auf den weitergeleitet wird auch antwortet.

Es ist auch möglich, über portforwarding eine zusätzliche "Firewall" gegen versteckte Hintertürln einzurichten:

Portforwarding für alle Ports auf eine nicht im Netz vergebene Adresse außerhalb des DHCP-Bereichs und alles ist zu!
Benutzerebene 3
Ja, der Server ist unter 192.168.0.9 aus dem LAN zu erreichen und antwortet auf http requests.
Über Festnetz-DSL ist der Server ebenfalls zu erreichen.
Beim Portscan via LTE komme ich bis zum Huawei.
Kann sogar die MAC-Adresse auslesen.
Doch bei den beiden freigegebenen Ports steht "filtered".
Firewall im Huawei ist aus.
Meiner Meinung nach liegt es an der Firmware des E5186.
Hab schon eine alternative Firmware aus dem Netz und suche nur noch das "Multicast Flash Tool".
Benutzerebene 7
Abzeichen +2
Ich habe ein Huawei selbst gekauft, nicht das selbe, eines mit Akku für mobilen Einsatz. Mit Firewall eingeschaltet funktioniert port forwarding, denn diese sind ja Ausnahmen von der Sperre durch die Firewall.

Nachtrag: Ich habe schon an unterschiedlichsten Modems an verschiedenen Anbietern erfolgreich port forwarding aufgesetzt, aber nie dabei die Modem-Firewall ausgeschaltet.
Benutzerebene 3
Es ist egal ob die Firewall am E5186 an oder aus ist. Forwarding funktioniert jedenfalls in beiden Fällen nicht.
Benutzerebene 7
Abzeichen +2
Mit den von Dir hier rein gestellten Einstellungen sollte es gehen. Vielleicht meldet sich ein A1-Mitarbeiter zu diesem Problem?
Benutzerebene 3
Das wäre ganz super wenn sich ein helfender A1-Engel um dieses Problem mal kümmern könnte.
Ein technischer Defekt des Routers ist auch nicht auszuschließen.
Benutzerebene 3
Hab ein bisschen gegoogelt und da fand ich, dass generell Huaweii LTE-Modems kein Port-Forwardung können wenn sie "gelockt" sind.
Benutzerebene 7
Abzeichen +2
Wenn im Modem auf 3G only umgestellt werden kann, wäre das leicht zu verifizieren.
Benutzerebene 7
Abzeichen +2
Gringolito

kann ich so nicht bestätigen, die Info, die du da ergoogelt hast. Ist wohl denkbar, dass es Betreiber Versionen von Geräten gibt, wo man nicht Port Forwarden kann, sollte bei unseren Geräten aber funktionieren.

Vielleicht hast du keine öffentliche IP Adresse und es scheitert daran. Kannst du auf http://www.a1.net/internet/firewall kontrollieren und umstellen (siehe auch einige andere Postings zu dem Thema hier in der Community).

lg
Hermann
Benutzerebene 7
Abzeichen +2
A1_Hermann schrieb:@Gringolito

kann ich so nicht bestätigen, die Info, die du da ergoogelt hast. Ist wohl denkbar, dass es Betreiber Versionen von Geräten gibt, wo man nicht Port Forwarden kann, sollte bei unseren Geräten aber funktionieren.

Vielleicht hast du keine öffentliche IP Adresse und es scheitert daran. Kannst du auf http://www.a1.net/internet/firewall kontrollieren und umstellen (siehe auch einige andere Postings zu dem Thema hier in der Community).

lg
Hermann
Adresse sollte laut Nachricht 6 aber schon öffentlich sein, nicht?
Benutzerebene 7
Abzeichen +2
ja stimmt, bei näherer Betrachtung scheint mir das keine typische private IP zu sein :manembarrassed:

Ich hab zwar keine Info dazu bekommen, dass Portforwarding nicht mehr funktionieren sollte, aber ich frage zur Sicherheit wieder einmal nach.
Benutzerebene 3
Hab sicher eine öffentliche IP!.
Warum glaubt mir hier niemand?
hab es schon mal getippselt:

Beim Portscan komme ich bis zum E5186.
Kann damit sogar die MAC-Adresse des E5186 auslesen.
Auch der E5186 sagt mir in den Einstellungen dass ich eine öffentl. IP habe.
Diese ist identisch mit jener die mir z.B. ping.eu liefert.

Nur dann ist es finster.
Entweder ist das Teil defekt oder Portforwarding ist bewußt gesperrt.
Benutzerebene 3
Es gibt da für Huawei-Modems eine sogenannte Toobox. Da kann man via Telnet auf die internen XML-Einstellungen zugreifen.
Auch da ist z.B. eine Äbderung der DNS nicht möglich. Bei dieser Firmware ist so ziemlich alles gesperrt.
Wollte die DSN mittels Toolbox gegen meine eigenen im LAN ändern um auf mein Intranet zugreifen zu können.
Zudem hat mein E5186 auch einen SIM-Lock!

Wenn man den DHCP im E5186 deaktiviert kriege ich keine IP mehr zugewiesen obwohl ich im LAN einen eigenen DHCP (mit meinen eigenen DNS) betreibe.
So bleibt mir nichts anderes übrig als WLAN + DHCP im E5186 zu deaktivieren und mein bisheriges 2,4-WLAN zu nutzen.
Benutzerebene 7
Abzeichen +2
,

hab (noch) keine ganz eindeutige Antwort bekommen.


Gringolito schrieb:
Meiner Meinung nach liegt es an der Firmware des E5186.
Sieht nach meinem bisherigen Infostand danach aus. Also dass es an der Firmware liegt und nicht (nur) am SIM Lock.

Schreib mir bitte, welche Firmware du genau nutzt und schick mir zur Sicherheit auch gleich die betroffene Rufnummer vom mobilen Internet per PM .

lg
Hermann
Benutzerebene 3
Es sieht so aus, als ob mit der aktuellen A1-Firmware (21.302.01.02.801) Portforwarding gesperrt ist. bzw nicht unterstützt wird.
Mit einem 3-Router (Hui) (Firmware: 21.306.01.04.22) funktioniert Portforwarding an meinem LTe-Zugang einwandfrei.
Auch ist ein Flashen einer alternativen Software nicht möglich. Föahsen läuft aber belbige wird vom A1-E5186 schlichtweg ignoriert. Danach steht noch immer 21.302.01.02.801 als Version drin.
Frage an A1 gibts eine aktuelle FW die Portworwarding unterstützt? Bin A1-Businesskund und erwarte mir daher schon ein bisserl mehr Service.
[Achtung, frustrierter User / rauer Ton :]
Kein Port Forwarding möglich?! Das wurde mir von dem Mitarbeiter im Online Shop bei Vertragsabschluss zugesichert! Wenn DAS stimmt, werde ich leider meinen Vertrag in der Probezeit beenden, da hier falsche Angaben zum verkauften Produkt gemacht wurden.

Ohne Port forwarding kann ich nicht arbeiten, abgesehen davon finde ich es ein starkes Stück, ein Modem zu verkaufen, bei dem alles gesperrt ist.

ber vielleicht ist ja alles halb so wild, könnte sich das einer der A1 Cracks ansehen? :robottongue:

Unten sind meine Daten:
Gerätename:E5186s-22a
Meine Nummer:Unbekannt
Hardware-Version:CL1E5175HM
Software-Version:21.302.01.02.801
Weboberflächen-Version:16.100.02.00.03
MAC-Adressen:XX:XX:XX:XX:XX:XX
WAN IP-Adresse:XX.XX.XX.XXX
Benutzerebene 3
Hallo!
Gibts schon eine Firmware die Portforwarding unterstützt? So kann ich nicht arbeiten!
Benutzerebene 7
Abzeichen +2
Hallo zusammen,

sorry für die späte Antwort haben diese Rückmeldung bekommen:

"Einstellung ist im WebUI möglich unter Einstellungen/Sicherheit/Virtueller Server (gilt auch für den Cube E5180).Wichtig ist auch die A1 Firewall entsprechend konfigurieren oder deaktivieren zu lassen. Ggfs. auch lokale Firewalls beachten und entsprechend konfigurieren."

Sind eigentlich Dinge, die wir schon wissen, ich frage also noch einmal nach.

@tomasioPointen
bin mir nicht sicher, was du schon alles probiert hast, ob du die A1 Firewall entsprechend eingestellt hast (öffentliche IP). Grundsätzlich geht es ja am Netcube.

Gringolito hat ja den Verdacht (der bisher nicht entkräftet werden konnte), dass es eben mit einer bestimmten Firmware auf dem 5186 nicht geht. (was aber nicht heißt, dass deshalb auf A1 Netcubes und technisch gleichwertigen Geräten für Internet über Mobilfunk, grundsätzlich nicht funktioniert).

lg
Hermann
Benutzerebene 3
Leider habe ich keinen Net-Cube. Der würde hier auch nicht funktionieren, da ohne Außenantennen kein LTE800-Empfang möglich ist.
Fakt ist, dass ich am E5186 die WAN-IP sehe.
Auch ping funktioniert zu dieser WAN-IP wenn ich in der E5186-Firewall "WAN-Pings" zulasse.

Wenn ich einen E5186 von T-Mobile mit A1-SIM anschließe sind auch, laut NMap (ZenMap), alle Ports bis auf 80, 53 und 5650 gesperrt. Weitere lassen sich auch auf dem T-Mobile-Router ebenfalls nicht aktivieren.

Wenn ich einen E5186 von "Drei" mit einer SIM von A1 anschließe sind erst mal alle Ports zu, lassen sich aber unter "virtueller Server" entsprechend öffnen und ansprechen.

Gerüchtweise hörte ich, dass Portforwarding auf dem E5186 mit A1-Firmware nur unter G3/HSPA+ funktioniert, nicht aber unter LTE. Könnte das mal jemand überprüfen. Habe hier leider kein G3/HSPA+.
Bei mir finde ich unter dem Link zur A1 Internet Firewall (https://www.a1.net/privat3/sec) nur die Fehlermeldung: »Mobile Sicherheit / Sie können dieses Service mit Ihrem Produkt leider nicht nutzen.Ihr A1 Service Team«

Könnte es sein, dass meine WAN-IP Adresse von A1 aus durch ein NAT läuft?

Mein Modem spuckt unter Geräteinformationen folgendes aus:
Gerätename:E5186s-22a
Meine Nummer:Unbekannt
Hardware-Version:CL1E5175HM
Software-Version:21.302.01.02.801
Weboberflächen-Version:16.100.02.00.03
MAC-Adressen:C8:51:95:97:60:38
WAN IP-Adresse:10.58.21.140

Antworten