Frage

Portforwarding, bitte!


Benutzerebene 1
Ich möchte nun auf einen Raspberry von außen zugreifen, deshalb bitte die Ports für meinen Anschluss freischalten.
Auch "always on" für meine neue 7580er Fritzbox aktivieren.

Vielen lieben Dank
Hans

25 Antworten

Always In ist bei der Fritz Box standard. Du benötigst, wenn noch nicht vorhanden, eine öffentliche IP
Benutzerebene 1
Eine IP habe ich natürlich, über die ich die Fritzbox von außen erreichen kann, nur wenn ich den Port dazu angebe (im meinem Fall Port 8123 von Home Assistant), kommt immer eine Fehlermeldung...
https://avm.de/service/fritzbox/fritzbox-7560/wissensdatenbank/publication/show/893_Statische-Portfreigaben-einrichten/
Benutzerebene 1
Danke, Jo, aber das habe ich auch schon durch... Der A1 Telefon Support hat auch gemeint, dass die Ports freigeschaltet werden müssen.
Festnetzinternet oder LTE?
Testest du auch von Extern mit einem Smartphone, mit DEAKTIVIERTEN WLAN?
Benutzerebene 1
Festnetz und Zugriff natürlich von außerhalb.
Zusammen gefasst:
du hast eine öffentliche IP, sprich die IP von myip.is und der Fritz Box sind gleich

Du hast die portweiterleitung in die Fritz Box, für den Dienst eingetragen. ( Screenshot?)

Und über ein externes gerät (Smartphone) funktioniert es nicht.

Dann liegt der Fehler nicht bei der und A1 hat wieder eine neue Problemstelle im Netz
Benutzerebene 1
Danke für Deine Mühe:
  • IP ist öffentlich, komme über 212.183.xxx.xxx auf die Fritzboxoberfläche
  • 212.183.xxx.xxx:8123 kann keine sichere Verbindung aufbauen
  • Screenshot ist angehängt


Kann es ein Zertifikatsproblem sein, weil wenn ich 212.183.xxx.xxx ansteuere, muss ich zuerst die Meldung "Dies ist keine sichere Verbindung" quittieren und auf "Weiter zu 212.183.xxx.xxx (unsicher)" klicken...
Und unter 10.0.0.39:8123 ist der Dienst erreichbar?
Benutzerebene 1
Im lokalen Netz funktioniert alles einwandfrei!
Da kommt auch der Zertifikatsfehler nicht.
Hast du bei hass ein Passwort gesetzt?
Edit: der Eintrag ist dir bekannt, oder: https://www.home-assistant.io/docs/configuration/remote/
Alternativ, aktivieren einfach das VPN auf der Fritz Box. Das ist sowie sicherer als direkter Zugriff auf den Client
Benutzerebene 4
Im lokalen Netz funktioniert alles einwandfrei!
Da kommt auch der Zertifikatsfehler nicht.

Zertifikatsfehler aufgrund IP-Adresse (wenns im lokalen Netz funktioniert, vermutlich auf 10.0.0.39 ausgestellt)
Welchen Port willst eigentlich auf den Raspberry durchtunneln (SSH sollte ja wohl kein Problem darstellen)?
Benutzerebene 1
Dieser Zertifikatsfehler von der FB kommt, wenn ich die öffentl. IP benutze, mit der lokalen tritt dieser nicht auf:



Wenn ich aber über 5txvislxxxxxxxxxxxx.myfritz.net verbinde, tritt der Zertifikatsfehler nicht auf, aber zum Port komme ich trotzdem nicht.
Benutzerebene 1
Port = 8123 von Home Assistant
Benutzerebene 1
Und dieser Fehler kommt, wenn ich mich von außen direkt auf den Port verbinde:

Benutzerebene 1
Grundsätzlich muss doch das Portforwarding eingeschaltet sein und es sollte auch noch die Firewall vom Internetzugang resettet bzw. abgeschaltet werden, oder?
Wer kann das machen???
Benutzerebene 4
Dieser Zertifikatsfehler von der FB kommt, wenn ich die öffentl. IP benutze, mit der lokalen tritt dieser nicht auf:



Wenn ich aber über 5txvislxxxxxxxxxxxx.myfritz.net verbinde, tritt der Zertifikatsfehler nicht auf, aber zum Port komme ich trotzdem nicht.

Die Information betreffend xxx.myfritz.net hat in den vorhergehenden Beiträgen gefehlt (@jo93 hat auch gefragt, ob Dienst unter 10.0.0.39:8123 erreichbar ist) also sieht es ganz danach aus als würde die Fritz!Box/HomeAssistant intern mittels NAT-Loopback und extern über die 212.183.x.x erreichbar sein. Betreffend Zertifikatsfehler gibt es einen älteren Artikel vom AVM-Support (selbstausgestelltes Zertifikat importieren)
Benutzerebene 1
Mein Raspberry (IP: 10.0.0.39) samt Home Assistant ist im lokalen Netz unter 10.0.0.39:8123 einwandfrei erreichbar.
Von unterwegs möchte ich mit 212.183.xxx.xxx:8123 oder 5txvislxxxxxxxxxxxx.myfritz.net:8123 auf den Raspberry zugreifen, funktioniert aber beides nicht.
Grundsätzlich muss doch das Portforwarding eingeschaltet sein und es sollte auch noch die Firewall vom Internetzugang resettet bzw. abgeschaltet werden, oder?
Wer kann das machen???
Benutzerebene 4
Mein Raspberry (IP: 10.0.0.39) samt Home Assistant ist im lokalen Netz unter 10.0.0.39:8123 einwandfrei erreichbar.
Von unterwegs möchte ich mit 212.183.xxx.xxx:8123 oder 5txvislxxxxxxxxxxxx.myfritz.net:8123 auf den Raspberry zugreifen, funktioniert aber beides nicht.
Grundsätzlich muss doch das Portforwarding eingeschaltet sein und es sollte auch noch die Firewall vom Internetzugang resettet bzw. abgeschaltet werden, oder?
Wer kann das machen???

EDIT: Screenshot von Fritz!Box mit hassbian übersehen, ich bin raus und verweise aufs Handbuch 😉

Hast du ein Passwort bei Home Assistent gesetzt?
Wenn nicht, wird es von extern nicht funktionieren.
Hast du HTTP://xxx.myfritz.net:8123 probiert?
Benutzerebene 1
DANKE!
Es ist http://xxx.myfritz.net:8123/ und NICHT httpS://xxx.myfritz.net:8123/!!!
Damit kann ich nun meine Poolsteuerung von außen erreichen!
Endlich... danke, nochmals!
Benutzerebene 5
Abzeichen +1
Zusammen gefasst:
du hast eine öffentliche IP, sprich die IP von myip.is und der Fritz Box sind gleich

Du hast die portweiterleitung in die Fritz Box, für den Dienst eingetragen. ( Screenshot?)

Und über ein externes gerät (Smartphone) funktioniert es nicht.

Dann liegt der Fehler nicht bei der und A1 hat wieder eine neue Problemstelle im Netz

jaja, die böse A1...
Sorry.
Zu dem Zeitpunkt bin ich nicht davon ausgegangen, dass es an so einer Kleinigkeit gescheitert ist.
Benutzerebene 1
Wer denkt auch an so was! :-)
Mit http://212.183.xxx.xxx:8123 habe ich es eh probiert gehabt, nur eben mit der http://xxx.myfritz.net Adresse eben nicht...

Antworten